Autor Thema: Keithley 179 TRMS Multimeter Anzeige defekt  (Gelesen 7430 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline frank1391

  • HiFi-Verrückter
  • ***
  • Beiträge: 396
  • Geschlecht: Männlich
  • ubi bene ibi Colonia
Keithley 179 TRMS Multimeter Anzeige defekt
« am: Dienstag, 08.Oktober.2013 | 21:26:49 Uhr »
Hallo zusammen, an einem Keithey 179 TRMS Multimeter ist die vierte 7-Segmentanzeige ausgefallen.

Bei jeder Messung leuchten mehr oder weniger alle Segmente. Ich sehe, daß die Segmente, die als Messergebnis angezeigt werden sollen, überstrahlen. Die Segmente, die aufgrund des Messergebnisses nicht angezeigt sein sollten, leuchten dennoch in "Normalstärke".  Leider habe ich keinen Schaltplan zum Gerät.

Ausser, daß ich alle Lötpunkte auf der Anzeigeplatine nachgelötet habe, habe ich erst einmal nichts unternommen. Ich dachte zuerst an den Tausch zweier 7seg-LEDs gegeneinander, meine aber, daß dies zur Lösung nicht beiträgt.

Auf der steckbaren Anzeigeplatine sind folgende Vielbeiner verbaut:
1. 75492PC (7-Segment Treiber)
2. 4114R-001-470 (Widerstands Array 47 Ohm, durchgemessen i.O.)
3. SCL4511BE (CMOS BCD-to-7-Segment LED Latch Decoder Drivers)

Hat jemand den Stromlaufplan oder einen Tipp was fehlerhaft sein könnte oder wo und was ich messen könnte.

Danke
Frank
« Letzte Änderung: Dienstag, 08.Oktober.2013 | 21:29:42 Uhr von frank1391 »

Offline frank1391

  • HiFi-Verrückter
  • ***
  • Beiträge: 396
  • Geschlecht: Männlich
  • ubi bene ibi Colonia
Re: Keithley 179 TRMS Multimeter Anzeige defekt
« Antwort #1 am: Dienstag, 08.Oktober.2013 | 21:27:56 Uhr »
...........und zwei weitere Bilder. Auf einem sieht man, daß wohl wegen des Fehlers bereits Segmentanzeigen getauscht wurden. Eines davon war an fünfter Stelle markiert, also wohl von der vierten dorthin.
« Letzte Änderung: Dienstag, 08.Oktober.2013 | 21:32:51 Uhr von frank1391 »

Offline uk64

  • HiFi-Urgestein
  • ****
  • Beiträge: 621
Re: Keithley 179 TRMS Multimeter Anzeige defekt
« Antwort #2 am: Dienstag, 08.Oktober.2013 | 21:48:18 Uhr »
Das wird ohne Schaltung nicht so einfach sein. Die Anzeige wird im Zeitmultiplex angesteuert werden, man sieht ja nur einen 75492 (treibt nur 6 Segmente). Der Treiber ist somit für alle Anzeigen zuständig.

Nachtrag: Es kann sein, das für die eine defekt Anzeige der Anodentreiber (75492 treibt die Kathode) einen Kurzschluss hat, die fehlerhafte Anzeige somit die Werte aller Anzeigen aufaddiert.
Kann man irgendwo Transistoren entdecken die für die Anoden zuständig sind?

Nachtrag 2: Habe Unsinn geschrieben.
Der 4511 ist der 7 Segment Treiber (Anode), der 75492 sorgt als Treiber für die Multiplexansteuerrung der Anzeigen (Kathode). Er kann daher als Ausfallursache infrage kommen.
Müsste man mit dem Oszi aber einfach messen können, im 75492 befinden sich nur 6 Inverter mit jeweils einem Eingang und einem Ausgang. Einfach alle Ein und Ausgänge nachmessen.

Gruß Ulrich
« Letzte Änderung: Dienstag, 08.Oktober.2013 | 22:15:59 Uhr von uk64 »

Offline frank1391

  • HiFi-Verrückter
  • ***
  • Beiträge: 396
  • Geschlecht: Männlich
  • ubi bene ibi Colonia
Re: Keithley 179 TRMS Multimeter Anzeige defekt
« Antwort #3 am: Dienstag, 08.Oktober.2013 | 22:24:14 Uhr »
Hallo Ulrich,
Auf der Hauptplatine ist in der Nähe ein Transistor zu sehen: F2N3904

Offline uk64

  • HiFi-Urgestein
  • ****
  • Beiträge: 621
Re: Keithley 179 TRMS Multimeter Anzeige defekt
« Antwort #4 am: Dienstag, 08.Oktober.2013 | 22:39:10 Uhr »
Vergesse das mit den Transistoren erst mal.
Das wird ja im Prinzip so



aussehen. Das Widerstandsarray weggelassen.
Die Inverter oben an der Kathode sitzen im 75492. Es darf immer nur eine Anzeige zur gleiche Zeit aktiv sein. Wenn nun ein Inverter im 75492 defekt ist  wird diese Anzeige immer angesteuert. Das kann man relativ einfach nachmessen. Die Pinbelegung des 75492 findet man im Netz.

Gruß Ulrich

Offline frank1391

  • HiFi-Verrückter
  • ***
  • Beiträge: 396
  • Geschlecht: Männlich
  • ubi bene ibi Colonia
Re: Keithley 179 TRMS Multimeter Anzeige defekt
« Antwort #5 am: Dienstag, 08.Oktober.2013 | 22:44:24 Uhr »
Habe gerade alle Eingänge des IC75492 am Oszi gehabt. Während die übrigen ein Rechtecksignal zeigen, ist am Eingang Pin 10 Nulllinie. An Pin 9  (Ausgang von Pin10!) ist ein Rechtecksignal
« Letzte Änderung: Dienstag, 08.Oktober.2013 | 22:53:29 Uhr von frank1391 »

Offline uk64

  • HiFi-Urgestein
  • ****
  • Beiträge: 621
Re: Keithley 179 TRMS Multimeter Anzeige defekt
« Antwort #6 am: Dienstag, 08.Oktober.2013 | 22:58:31 Uhr »
So ganz passt das nicht, die Pins richtig gezählt?
Das Ding hat ja 6 Inverter und nur 5 werden benötigt, vielleicht nur den Unbenutzten erwischt.



Von der defekten zweiten Anzeige geht eine Leiterbahn zu einem Ausgang des 75492, ich kann es auf dem Bild erkennen, es könnte Pin 6 sein.
Wenn dann müsste man dort einen Unterschied messen können.

Gruß Ulrich

Offline frank1391

  • HiFi-Verrückter
  • ***
  • Beiträge: 396
  • Geschlecht: Männlich
  • ubi bene ibi Colonia
Re: Keithley 179 TRMS Multimeter Anzeige defekt
« Antwort #7 am: Dienstag, 08.Oktober.2013 | 23:23:13 Uhr »
Pin 10 ist zur Stiftleiste geführt. Kein Signal am Oszi. Richtig, Pin 6 geht zur defekten Anzeige.

Mom, ich messe nochmals die übrigen Eingänge Pin 14, 12, 10, 8, 5, 3. An den Ausgängen sind die Signale verzerrt. gegen Masse Geräteeingangsbuchse gemessen.

Offline frank1391

  • HiFi-Verrückter
  • ***
  • Beiträge: 396
  • Geschlecht: Männlich
  • ubi bene ibi Colonia
Re: Keithley 179 TRMS Multimeter Anzeige defekt
« Antwort #8 am: Dienstag, 08.Oktober.2013 | 23:30:27 Uhr »
Dann wird Pin 10 wohl als 6ter nicht versorgt. Nur an Pin 13 sehe ich ein sauberes ausgängiges Rechtecksignal. Alle anderen Ausgänge sind unterschiedlich aber stark verzerrt; als Rechtecksignal nicht mehr zu erkennen.  Pin 9 hat als Ausgang von Pin 10 kein Signal

Offline frank1391

  • HiFi-Verrückter
  • ***
  • Beiträge: 396
  • Geschlecht: Männlich
  • ubi bene ibi Colonia
Re: Keithley 179 TRMS Multimeter Anzeige defekt
« Antwort #9 am: Dienstag, 08.Oktober.2013 | 23:40:43 Uhr »
Pin 6 des IC75492 geht zur gemeinsamen Kathode der Anzeige

Offline uk64

  • HiFi-Urgestein
  • ****
  • Beiträge: 621
Re: Keithley 179 TRMS Multimeter Anzeige defekt
« Antwort #10 am: Dienstag, 08.Oktober.2013 | 23:47:40 Uhr »
Mit den Messungen kann ich nicht wirklich was Anfangen.

Löte doch mal Pin 6 vom 75492 ab. Die zweite Stelle sollte dann dunkel bleiben.

Gruß Ulrich

Offline frank1391

  • HiFi-Verrückter
  • ***
  • Beiträge: 396
  • Geschlecht: Männlich
  • ubi bene ibi Colonia
Re: Keithley 179 TRMS Multimeter Anzeige defekt
« Antwort #11 am: Mittwoch, 09.Oktober.2013 | 00:09:27 Uhr »
Entschuldigung, in meinem Beitrag #6 ist ein Fehler! Pin 9 hat kein Ausgangssignal. Also gibt es fünf saubere Eingangssignale.
Du siehst ja auf den Bildern, daß durch einen früheren Tausch der Anzeigen 4 und 5 die Leiterbahnen bzw. Lötpunkte schon angebruzelt sind. Ablöten möchte ich da nur mit meiner Entlötstation. Die macht aber relativ viel Krach, sodaß meine nebenan schlafende Frau sicher wach würde. Können wir das auf Morgen verschieben ?  Ist es denn noch nötig nach der korrigierten Aussage bzgl. Pin9?

Wie müßten die abgehenden Signale aussehen auch saubere Rechtecksignale? Wenn ja: Den Oszitaster schließe ich mit der Krokoklemme an die Minus-Prüfbuchse des Gerätes. Ist das richtig?
« Letzte Änderung: Mittwoch, 09.Oktober.2013 | 00:11:54 Uhr von frank1391 »

Offline uk64

  • HiFi-Urgestein
  • ****
  • Beiträge: 621
Re: Keithley 179 TRMS Multimeter Anzeige defekt
« Antwort #12 am: Mittwoch, 09.Oktober.2013 | 00:22:25 Uhr »
Die schwarze Messbuchse muss nicht mit der Gerätemasse identisch sein.
Ich würde mir hier eine Masse auf der Displayplatine suchen, gerade bei den Digitalgeschichten fängt man sich über Masseströme schnell Unsinn ein.
Ein sauberes Signal am Ausgang oder auch nicht ist hier von weitem schwer zu beantworten,
in Abhängigkeit der angesteuerten  Segmente ändert sich ja der Strom durch die Inverter.
Eine 1 bracht halt weniger Strom als eine 8.

Du kannst auch einfach umlöten und den unbenutzten Inverter verwenden.
Ich verwende für so etwas übrigens bis heute die gute alte Endlötlitze, sauber und geräuschlos.
Der Lötkolben muss allerdings heiß genug sein, viele Hobbyisten sind hier zu vorsichtig und arbeiten mit zu geringer Temperatur.

Gruß Ulrich

Offline frank1391

  • HiFi-Verrückter
  • ***
  • Beiträge: 396
  • Geschlecht: Männlich
  • ubi bene ibi Colonia
Re: Keithley 179 TRMS Multimeter Anzeige defekt
« Antwort #13 am: Mittwoch, 09.Oktober.2013 | 00:25:14 Uhr »
Ulrich, ich habe ja alle Messungen ohne "Last", also ohne irgendetwas am Messeingang des DMM durchgeführt. Die Anzeige variiert aber in der letzen Stelle etwas, wie bei vielen DMM.

Jetzt kommts: Immer wenn in der Anzeige Nr 1 das Minus-Zeichen erscheint, habe ich an PIN 9 ein sauberes Rechtecksignal. Die Aussage in Beitrag #6 war also für den Zeitraum des erleuchteten Minuszeichensdoch nicht falsch.

Offline frank1391

  • HiFi-Verrückter
  • ***
  • Beiträge: 396
  • Geschlecht: Männlich
  • ubi bene ibi Colonia
Re: Keithley 179 TRMS Multimeter Anzeige defekt
« Antwort #14 am: Mittwoch, 09.Oktober.2013 | 00:44:06 Uhr »
Ich nehme jetzt die Masse an einem Federblech ab, das normalerweise auf eine Abschirmplatte drückt. Es hat sich dadurch jedoch nichts geändert.
Würde jetzt gerne Schluß machen und mich Morgen wieder melden. Dann werde ich auch vorab ein paar Bilder mehr liefern, insbesondere mit den Ausgangssignalen.
Vielleicht finde ich doch im Netz noch einen SLP, habe allerdings bereits heute lange gesucht. Im Radiomuseum scheint er zu sein, da muß man sich aber kostenpflichtig anmelden.

Gute Nacht und vielen Dank!

Offline frank1391

  • HiFi-Verrückter
  • ***
  • Beiträge: 396
  • Geschlecht: Männlich
  • ubi bene ibi Colonia
Re: Keithley 179 TRMS Multimeter Anzeige defekt
« Antwort #15 am: Mittwoch, 09.Oktober.2013 | 20:27:29 Uhr »
Hallo Ulrich,
richtig, bei abgelötetem Pin 6 des IC75492 erlischt Anzeige 4. Dienoch funktionierenden Anzeigen strahlen sehr deutlich heller.



Folgende Aufnahmen wurden bei einer konstanten Spannung von 100mV DC gemacht. Angezeigt werden 100,06 bis 100,07mV aber mit dem Fehler in Anzeige 4.

Pin1


Pin2


Pin3



Pin4


Pin5


Pin6


Pin7


Pin8


Pin9


Pin10



Pin11


Pin12


Pin13


Pin14


Noch zwei Bilder vom Innenleben:







Die Fa. Keithley ruft Morgen zurück, ich hoffe mit der guten Nachricht mir den SLP zu schicken.

Gruß
Frank
« Letzte Änderung: Mittwoch, 09.Oktober.2013 | 21:46:46 Uhr von Jürgen Heiliger »

Offline uk64

  • HiFi-Urgestein
  • ****
  • Beiträge: 621
Re: Keithley 179 TRMS Multimeter Anzeige defekt
« Antwort #16 am: Mittwoch, 09.Oktober.2013 | 20:30:07 Uhr »
Hallo Frank,
ich kann keine Bilder sehen.
Es erscheint nur "Keine Datei zum Anzeigen vorhanden (oder Du hast keine Berechtigung, das Album zu sehen)"

Edit: Vergess es, ich hatte den ersten Satz nicht gelesen.

Gruß Ulrich
« Letzte Änderung: Mittwoch, 09.Oktober.2013 | 20:35:00 Uhr von uk64 »

Offline frank1391

  • HiFi-Verrückter
  • ***
  • Beiträge: 396
  • Geschlecht: Männlich
  • ubi bene ibi Colonia
Re: Keithley 179 TRMS Multimeter Anzeige defekt
« Antwort #17 am: Mittwoch, 09.Oktober.2013 | 21:07:18 Uhr »
Hallo Ulrich, geschafft.

Gruß
Frank
« Letzte Änderung: Mittwoch, 09.Oktober.2013 | 21:19:38 Uhr von frank1391 »

Offline frank1391

  • HiFi-Verrückter
  • ***
  • Beiträge: 396
  • Geschlecht: Männlich
  • ubi bene ibi Colonia
Re: Keithley 179 TRMS Multimeter Anzeige defekt
« Antwort #18 am: Mittwoch, 09.Oktober.2013 | 21:30:04 Uhr »
Da ist noch Einiges falsch verlinkt mit anderen größeren Ansichten beim Klick aufs Bild. Im Text sehe ich über 2 Bildern URLs die da nichts zu suchen haben. Jürgen wirds richten.

Jürgen, wenn ich die URL in der Galerie kopiere, im Beitrag einfüge und anschließend ändere, bleibt die Verknüpfung zur alten Großansicht bestehen.
« Letzte Änderung: Mittwoch, 09.Oktober.2013 | 21:37:36 Uhr von frank1391 »

Offline uk64

  • HiFi-Urgestein
  • ****
  • Beiträge: 621
Re: Keithley 179 TRMS Multimeter Anzeige defekt
« Antwort #19 am: Mittwoch, 09.Oktober.2013 | 21:36:40 Uhr »
Bei den Messungen war Pin 6 wieder angelötet?

Messung dieser Art aber bitte mit DC Kopplung und Angabe der Nulllinie. TV Seperator auf Off.

Ansonsten, Standard Intersil AD Umsetzer. Die Schaltung kann man sich zusammenreimen.

Gruß Ulrich

Offline frank1391

  • HiFi-Verrückter
  • ***
  • Beiträge: 396
  • Geschlecht: Männlich
  • ubi bene ibi Colonia
Re: Keithley 179 TRMS Multimeter Anzeige defekt
« Antwort #20 am: Mittwoch, 09.Oktober.2013 | 21:39:15 Uhr »
Ja Pin 6 war angelötet und die Prügel nehme ich an, habe ich schlichtweg übersehen :0keule. Alles neu machen?
« Letzte Änderung: Mittwoch, 09.Oktober.2013 | 21:41:56 Uhr von frank1391 »

Offline uk64

  • HiFi-Urgestein
  • ****
  • Beiträge: 621
Re: Keithley 179 TRMS Multimeter Anzeige defekt
« Antwort #21 am: Mittwoch, 09.Oktober.2013 | 21:44:16 Uhr »
Wenn keine weiteren Messfehler vorliegen ist das IC 75492 kaputt.

Gruß Ulrich

Offline frank1391

  • HiFi-Verrückter
  • ***
  • Beiträge: 396
  • Geschlecht: Männlich
  • ubi bene ibi Colonia
Re: Keithley 179 TRMS Multimeter Anzeige defekt
« Antwort #22 am: Mittwoch, 09.Oktober.2013 | 21:50:44 Uhr »
Danke Ulrich, werde mir das dann besorgen und berichten.

Gruß
Frank

Offline uk64

  • HiFi-Urgestein
  • ****
  • Beiträge: 621
Re: Keithley 179 TRMS Multimeter Anzeige defekt
« Antwort #23 am: Mittwoch, 09.Oktober.2013 | 22:19:44 Uhr »
Die Beschaffung des ICs könnte ein Problem werden.
Man kann den Teil des ICs aber relativ einfach diskret ersetzen.
Anstelle des IC Inverters:



Oder man nimmt einen so genannten  "Digitaltransistor" DTCxxx,  der enthält schon die beiden Widerstände.

Gruß Ulrich

Offline frank1391

  • HiFi-Verrückter
  • ***
  • Beiträge: 396
  • Geschlecht: Männlich
  • ubi bene ibi Colonia
Re: Keithley 179 TRMS Multimeter Anzeige defekt
« Antwort #24 am: Mittwoch, 09.Oktober.2013 | 22:38:58 Uhr »
« Letzte Änderung: Donnerstag, 10.Oktober.2013 | 10:06:09 Uhr von frank1391 »

Offline frank1391

  • HiFi-Verrückter
  • ***
  • Beiträge: 396
  • Geschlecht: Männlich
  • ubi bene ibi Colonia
Re: Keithley 179 TRMS Multimeter Anzeige defekt
« Antwort #25 am: Mittwoch, 16.Oktober.2013 | 20:42:10 Uhr »
Hallo Ulrich, melde Vollzug !

Das IC war defekt.

Danke für die Hilfe.

Gruß
Frank